"동일한 ID를 가진 클라이언트가 이미 등록되었습니다" 및 "에이전트가 이미 등록되었습니다. 백업 콘솔에서 에이전트를 등록 취소하십시오"로 에이전트 등록이 실패합니다. 팔로우

증상
- 클라우드에서 에이전트 시스템을 등록하려고 합니다.
- 등록 실패 (에이전트 등록을 취소하려고 하면 실패) MMS 로그를 확인할 때 다음 오류가 표시됩니다.
[RestApi] [에이전트 등록] 상태 : 수동 등록 취소 필요, 코드 : 409, 이유 : '클라이언트 등록 실패 : { "도메인": "계정 서버", "이유": "ReasonClientAlreadyRegistered", "context": { "client_id": "A180B7F6-5E8D-4677-AB05-2586B3677590"}, "debug": { "msg": "동일한 ID를 가진 클라이언트가 이미 작성되었습니다"}, "code": "ReasonClientAlreadyRegistered"} '
- "에이전트가 이미 등록되었습니다. 백업 콘솔에서 에이전트를 등록 취소하십시오"라는 메시지로 에이전트를 수동으로 등록하지 못했습니다.

원인
등록 후 머신이 다른 관리 서버로 마이그레이션 되었거나 이미 등록된 다른 머신의 이미지에서 머신이 복원된 경우 이러한 문제가 발생할 수 있습니다.
시스템 ID와 함께 시스템을 완전히 삭제해야 합니다 (일반 제거 프로세스 중에 삭제되지 않음).

해결 방법
- 문제 머신에 로그인
- 에이전트를 설치 제거하십시오. 제거 과정에서 "로그 및 구성 설정 제거"확인란을 선택하십시오.
- 머신에서 기존 ID를 제거하십시오.
Windows :
● 머신에서 레지스트리 편집기를 여십시오 : 시작> 실행> regedit \
● 다음 키로 이동하십시오.
HKEY_LOCAL_MACHINE \ Software \ Acronis \ BackupAndRecovery \ Settings \ MachineManager
다음 하위 키를 삭제하십시오.
● 인스턴스 ID
● MMSCurrentMachineID
Mac OS :
● / Library / Application Support / Acronis / Registry / BackupAndRecovery.config 에서 InstanceID 및
MMSCurrentMachineID 값을 제거하십시오.
Linux
● /etc/Acronis/BackupAndRecovery.config에서 InstanceID 및 MMSCurrentMachineID 값을 제거하십시오.
- 최신 설치 프로그램을 사용하여 에이전트를 다시 설치하십시오.
그래도 문제가 해결되지 않으면 영향을 받는 에이전트 시스템에서 새 시스템 보고서를 수집하여 Acronis 고객 센터에 문의하십시오.

참조 - https://kb.acronis.com/content/62866