MMS 서비스를 시작할 수 없습니다. "오류 0x30002 : CannotBind" 팔로우
증상
관리 서버에서 Acronis 에이전트에 머신을 등록하려고 합니다. 등록에 실패했습니다. Acronis Managed Machine 서비스를 확인하고 중지되었음을 확인합니다.
서비스를 시작하려고 하면 다음 오류 (Windows 이벤트 로그에 기록됨 )가 표시됩니다.
오류 0xb9000b : 네트워크 모듈을 초기화하지 못했습니다.
| 추적 레벨 : 오류
| 줄 : 0xb957662f70a242f
| 파일 : e : \ 327 \ enterprise \ service \ impl \ server.cpp : 678
| 함수 : Core :: ServerImpl :: StartNetworkServer
| $ 모듈 : mms_vsa64_12420
|
| 오류 0x30002 : CannotBind
| 줄 : 0xe6f03fbb500414fa
| 파일 : e : \ 327 \ enterprise \ common \ async_ipc \ async \ io_base_libevent.cpp : 371
| 함수 : AsyncIpc :: Libevent :: IoBase :: Activate
| $ 모듈 : asyncipc_vsa64_12420
원인
포트 9850을 사용하는 소프트웨어를 확인하십시오.
해결 방법
Windows :
1. 실행 :
netstat -ant | findstr 9850
9850에서 수신하는 프로세스의 PID를 찾습니다.
2. 실행 :
tasklist /fi "pid eq <PID>
여기서 <PID>는 1 단계에서 찾은 프로세스 ID입니다.
Linux :
1. 실행 :
netstat -tanp | grep 9850
9850에서 수신하는 프로세스의 PID를 찾습니다.
2. 실행 :
ps -p <PID> -o comm=
여기서 <PID>는 1 단계에서 찾은 프로세스 ID입니다.
현재 제품 설계에서는 Acronis Agent에 대해이 포트를 변경할 수 없습니다. 다른 포트를 사용하려면 타사 응용 프로그램의 설정을 변경하십시오.
Acronis 개발 팀은 Acronis 소프트웨어에서 이 포트 구성을 변경 하는 옵션을 개발 중입니다.
참조 - https://kb.acronis.com/content/63212